BETA

13th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [13/03/19 05:01 PM] with 'Major Outage'

Issue has been resolved at [13/03/19 05:02 PM]