BETA

12th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/12/17 05:40 AM] with 'Major Outage'

Issue has been resolved at [12/12/17 05:41 AM]