BETA

10th December 2016

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [10/12/16 02:22 AM] with 'Major Outage'

Issue has been resolved at [10/12/16 02:28 AM]