BETA

13th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/03/19 04:57 PM] with 'Partial Outage'

Issue has been resolved at [13/03/19 05:03 PM]