BETA

10th December 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [10/12/16 12:08 AM] with 'Partial Outage'

Issue has been resolved at [10/12/16 12:18 AM]