BETA

8th December 2016

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [08/12/16 12:05 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [08/12/16 12:14 AM]