BETA

20th June 2016

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [20/06/16 07:18 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [20/06/16 07:40 AM]