BETA

7th December 2016

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [07/12/16 11:55 AM] with 'Partial Outage'

Issue has been resolved at [07/12/16 12:05 PM]