BETA

12th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [12/12/17 02:56 AM] with 'Partial Outage'

Issue has been resolved at [12/12/17 03:02 AM]