BETA

20th June 2016

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [20/06/16 07:10 AM] with 'Major Outage'

Issue has been resolved at [20/06/16 07:40 AM]