BETA

12th December 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [12/12/17 12:41 AM] with 'Major Outage'

Issue has been resolved at [12/12/17 12:46 AM]