BETA

13th March 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/03/19 02:35 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/03/19 02:47 PM]