BETA

11th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/12/17 10:54 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/12/17 10:58 PM]