BETA

20th June 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [20/06/16 07:05 AM] with 'Partial Outage'

Issue has been resolved at [20/06/16 07:06 AM]