BETA

11th December 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [11/12/17 09:27 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/12/17 09:39 PM]