BETA

11th December 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [11/12/17 09:14 PM] with 'Major Outage'

Issue has been resolved at [11/12/17 09:17 PM]