BETA

17th April 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [17/04/19 09:58 PM] with 'Major Outage'

Issue has been resolved at [17/04/19 09:59 PM]