BETA

17th April 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [17/04/19 04:22 PM] with 'Partial Outage'

Issue has been resolved at [17/04/19 04:25 PM]