BETA

16th April 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [16/04/19 08:47 PM] with 'Partial Outage'

Issue has been resolved at [16/04/19 08:49 PM]