BETA

13th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/04/19 06:08 PM] with 'Partial Outage'

Issue has been resolved at [13/04/19 06:10 PM]