BETA

13th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/04/19 05:55 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/04/19 06:01 PM]