BETA Singapore cluster       Mumbai cluster

13th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/04/19 05:44 PM] with 'Partial Outage'

Issue has been resolved at [13/04/19 05:45 PM]