BETA

12th April 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/04/19 06:57 PM] with 'Partial Outage'

Issue has been resolved at [12/04/19 06:59 PM]