BETA

12th April 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [12/04/19 09:05 AM] with 'Partial Outage'

Issue has been resolved at [12/04/19 09:08 AM]