BETA

11th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [11/04/19 09:49 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/04/19 09:53 PM]