BETA

11th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [11/04/19 08:56 PM] with 'Partial Outage'

Issue has been resolved at [11/04/19 08:58 PM]