BETA

11th April 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [11/04/19 11:20 AM] with 'Partial Outage'

Issue has been resolved at [11/04/19 11:22 AM]