BETA

11th April 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [11/04/19 11:07 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/04/19 11:16 AM]