BETA

10th April 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [10/04/19 04:45 PM] with 'Partial Outage'

Issue has been resolved at [10/04/19 04:49 PM]