BETA

8th April 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [08/04/19 02:38 PM] with 'Major Outage'

Issue has been resolved at [08/04/19 02:44 PM]