BETA

8th April 2019

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [08/04/19 02:05 PM] with 'Partial Outage'

Issue has been resolved at [08/04/19 02:07 PM]