BETA

7th April 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [07/04/19 10:02 PM] with 'Major Outage'

Issue has been resolved at [07/04/19 10:03 PM]