BETA

6th April 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [06/04/19 01:59 PM] with 'Major Outage'

Issue has been resolved at [06/04/19 02:28 PM]