BETA

11th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/12/17 07:39 PM] with 'Partial Outage'

Issue has been resolved at [11/12/17 07:40 PM]