BETA

4th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [04/04/19 05:10 PM] with 'Partial Outage'

Issue has been resolved at [04/04/19 05:13 PM]