BETA

4th April 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [04/04/19 12:31 PM] with 'Major Outage'

Issue has been resolved at [04/04/19 01:04 PM]