BETA

4th April 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [04/04/19 12:31 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [04/04/19 03:23 PM]