BETA

3rd April 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [03/04/19 05:14 PM] with 'Partial Outage'

Issue has been resolved at [03/04/19 05:17 PM]