BETA

3rd April 2019

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [03/04/19 12:53 PM] with 'Partial Outage'

Issue has been resolved at [03/04/19 01:01 PM]