BETA

3rd April 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [03/04/19 03:22 AM] with 'Major Outage'

Issue has been resolved at [03/04/19 03:23 AM]