BETA

2nd April 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [02/04/19 09:43 PM] with 'Partial Outage'

Issue has been resolved at [02/04/19 09:46 PM]