BETA

2nd April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [02/04/19 08:56 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [02/04/19 08:57 PM]