BETA

11th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/12/17 06:28 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/12/17 06:31 PM]