BETA

11th December 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [11/12/17 06:26 PM] with 'Partial Outage'

Issue has been resolved at [11/12/17 07:08 PM]