BETA

1st April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [01/04/19 10:45 PM] with 'Partial Outage'

Issue has been resolved at [01/04/19 10:48 PM]