BETA

11th December 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/12/17 06:01 PM] with 'Major Outage'

Issue has been resolved at [11/12/17 06:02 PM]