BETA

11th December 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/12/17 05:54 PM] with 'Partial Outage'

Issue has been resolved at [11/12/17 05:55 PM]