BETA

1st April 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [01/04/19 12:51 PM] with 'Major Outage'

Issue has been resolved at [01/04/19 01:00 PM]