BETA

1st April 2019

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [01/04/19 07:35 AM] with 'Partial Outage'

Issue has been resolved at [01/04/19 07:39 AM]