BETA

1st April 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [01/04/19 06:45 AM] with 'Partial Outage'

Issue has been resolved at [01/04/19 06:46 AM]